BRAZHKO.info

Блог о компьютерном железе и IT-технологиях

Откат на Firefox 2 в Hardy Heron

| комментариев 6

1. Удаляем Firefox 3 и сопутствующие пакеты:

$ sudo apt-get purge firefox firefox-3.0 firefox-3.0-gnome-support

2. Устанавливаем Firefox 2:

$ sudo apt-get install firefox-2 firefox-2-gnome-support mozilla-firefox-locale-ru-ru

3. Исправляем значок запуска на панели Gnome:

  • удаляем старый;
  • созаём новый: Приложения — Интернет — Firefox 2 Web Browser — Добавить эту кнопку запуска на панель.

Основная причина отката — отсутствие Google Toolbar для Firefox 3.0 Beta 5. Хотя наличие расширений Яндекс.Бар и Яндекс.Фотки для FF 3b5 порадовало.

6 комментария

  1. А настройки сохранятся?

  2. Это ты зря. Если он у тебя уже установлен из старых версий, то найди ту папку и в install.rdf подними maxVersion

    Если не установлен, то скачай панель (xpi), распакуй тоже подправь install.rdf и запакуй обратно. Потом открой как файл и установи. Гугловая панель работает, вон у меня болтается.

  3. После удаления ff3 и установки ff2, на имя ‘firefox’ в консоли никто не отзывается. Вместо этого apt-get предлагает установить ‘firefox’, т.е. firefox 3 beta 5.
    У меня вопрос: как бы сказать убунте, что firefox-2 на самом деле firefox?

  4. 2 div
    Я удалил ~/.mozilla/firefox от 3b5 и положил туда одноимённую папку от FF 2 из Gutsy.
    На счёт обратной совместимости не уверен. Знаю только, что настройки панелей слетают, а дальше не копал.

    2 tigro
    Работать-то оно работает, вот только с шириной панели проблемы. При всех достоинствах 3b5 пока посижу на FF 2. Привычней как-то 🙂

    2 fabian
    $ sudo cp -l /usr/bin/firefox-2 /usr/bin/firefox
    Подойдёт?

  5. Не надо ничего распаковывать, чтобы установить неподдерживаемое расширение. Поставьте расширение Nightly Tester Tools http://www.oxymoronical.com/web/firefox/nightly . Google toolbar устанавливайте по прямой ссылке, http://dl.google.com/firefox/google-toolbar-linux.xpi

  6. всё впроще
    about:config
    — «да буду аккуратен»
    новый ключ — boolean
    extensions.checkCompatibility;false

Добавить комментарий

Войти с помощью: 

Обязательные поля отмечены *.